import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-i)^[\\t ]*((?:[!(]|\\w+\\(|(?:(?:const|let|var)[\\t ]+)?[\\w$]+[\\t ]*[:=][\\t ]*(?:\\{\\w+[\\t ]*:[\\t ]*)?)?)((?:\\([^\\r\\n)]*\\)|\\w)[\\t ]*=>)";
final String string = "!function(){}(); // test1\n"
+ "!function test2(){}(); // test2\n"
+ "(function(){})(); // test3\n"
+ "(function test4(){})(); // test4\n"
+ "test5 = function(){} // test5\n"
+ "test6 = function _test6(){} // test6\n"
+ "let test7 = function(){} // test7\n"
+ "let test8 = function _test8(){} // test8\n"
+ "var test9 = function(){} // test8\n"
+ "var test10 = function _test10(){} // test10\n"
+ "const test11 = function(){} // test11\n"
+ "const test12 = function _test12(){} // test12\n"
+ "myfunc(function(){}) // test13\n"
+ "myfunc(function test14(){}) // test14\n"
+ "let myobj15 = {test15 : function(){}} // test15\n"
+ "let myobj16 = {test16 : function _test16(){}} // test16\n"
+ "var myobj17 = {test17 : function(){}} // test17\n"
+ "var myobj18 = {test18 : function _test18(){}} // test18\n"
+ "const myobj19 = {test19 : function(){}} // test19\n"
+ "const myobj20 = {test20 : function _test20(){}} // test20\n"
+ "!function(a){}(); // test21\n"
+ "!function test22(b){}(); // test22\n"
+ "(function(c){})(); // test23\n"
+ "(function test24(d){})(); // test24\n"
+ "test25 = function(e){} // test25\n"
+ "test26 = function _test26(f){} // test26\n"
+ "let test27 = function(g){} // test27\n"
+ "let test28 = function _test28(h){} // test28\n"
+ "var test29 = function(i){} // test29\n"
+ "var test30 = function _test30(j){} // test30\n"
+ "const test31 = function(k){} // test31\n"
+ "const test32 = function _test32(l){} // test32\n"
+ "myfunc(function(m){}) // test33\n"
+ "myfunc(function test34(n){}) // test34\n"
+ "let myobj35 = {\n"
+ " test35 : function(o){} // test35\n"
+ "}\n"
+ "let myobj36 = {\n"
+ " test36 : function _test36(p){} // test36\n"
+ "}\n"
+ "var myobj37 = {\n"
+ " test37 : function(q){} // test37\n"
+ "}\n"
+ "var myobj38 = {\n"
+ " test38 : function _test38(r){} // test38\n"
+ "}\n\n"
+ "test39 = () => {} // test39\n"
+ "test40 = v => {} // test40\n"
+ "test41 = (w) => {} // test41\n"
+ "test42 = (x,y) => {} // test42\n\n"
+ "let test43 = v => {} // test43\n"
+ "var myobj44 = {test44 : (w) => {}} // test44\n"
+ "const myobj45 = {\n"
+ " test45 : (x,y) => {} // test45\n"
+ "}\n"
+ "myfunc(() => {}) // test46\n"
+ "myfunc(v => {}) // test47\n\n"
+ "function test48(){} // test48\n"
+ "function test49(s){} // test49\n"
+ "function test50(t,u){} // test50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}