import re
regex = re.compile(r"(?s)<table.*?<\/table>", flags=re.MULTILINE)
test_str = ("<table style=\"width: 900px; height: 156px;\">\n"
"<tbody>\n"
"<tr>\n"
"<td><span style=\"color: #37454d;\"><strong>Resort Name:</strong></span></td>\n"
"<td style=\"text-align: left;\"><span style=\"color: #37454d;\">explora Valle \n"
"Sagrado, Peru</span></td>\n"
"</tr>\n"
"<tr>\n"
"<td><span style=\"color: #37454d;\"><strong>Country Name:</strong></span></td>\n"
"<td><span style=\"color: #37454d; font-family: arial, helvetica, sans-serif; \n"
"font-size: 13px; font-style: normal; font-variant-ligatures: normal; font- \n"
"variant-caps: normal; font-weight: normal; letter-spacing: normal; text- \n"
"align: left; text-indent: 0px; text-transform: none; white-space: normal; \n"
"word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color: \n"
"#ffffff; text-decoration-style: initial; text-decoration-color: initial; \n"
"float: none; display: inline !important;\">Peru</span></td>\n"
"</tr>\n"
"<tr>\n"
"<td><span style=\"color: #37454d;\"><strong>Resort Address:</strong></span> \n"
"</td>\n"
"<td>\n"
"<div class=\"is-hidden-mobile blEntry address ui_link \" data-popover=\"small\" \n"
"data-position=\"below\" data-element=\".content\" data- \n"
"options=\"closeOnMouseAway\" data-maxwidth=\"300\" data-mapfilters=\"\"> \n"
"<span>Unnamed Rd Urquillos, Peru</span></div>\n"
"</td>\n"
"</tr>\n"
"<tr>\n"
"<td><span style=\"color: #37454d;\"><strong>Website:</strong></span></td>\n"
"<td>\n"
"<p><span style=\"color: #37454d;\">https://www.explora.com/hotels-and- \n"
"travesias/sacred-valley-peru/</span></p>\n"
"</td>\n"
"</tr>\n"
"<tr>\n"
"<td><span style=\"color: #37454d;\"><strong>Phone:</strong></span></td>\n"
"<td><span style=\"color: #37454d;\">+56 2 2395 2580</span></td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"<p><iframe style=\"border:0\" src=\"https://www.google.com/maps/embed? \n"
"pb=!1m14!1m8!1m3!1d15528.573314149919!2d-72.0483157!3d- \n"
"13.341359!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x0%3A0x1a052e519e34e771!\n"
"2sExplora+Valle+Sagrado!5e0!3m2!1sen!2sjp!4v1531275200849\" height=\"450\" \n"
"width=\"600\"></iframe></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")