// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)<table.*?<\/table>").unwrap();
let string = "<table style=\"width: 900px; height: 156px;\">
<tbody>
<tr>
<td><span style=\"color: #37454d;\"><strong>Resort Name:</strong></span></td>
<td style=\"text-align: left;\"><span style=\"color: #37454d;\">explora Valle
Sagrado, Peru</span></td>
</tr>
<tr>
<td><span style=\"color: #37454d;\"><strong>Country Name:</strong></span></td>
<td><span style=\"color: #37454d; font-family: arial, helvetica, sans-serif;
font-size: 13px; font-style: normal; font-variant-ligatures: normal; font-
variant-caps: normal; font-weight: normal; letter-spacing: normal; text-
align: left; text-indent: 0px; text-transform: none; white-space: normal;
word-spacing: 0px; -webkit-text-stroke-width: 0px; background-color:
#ffffff; text-decoration-style: initial; text-decoration-color: initial;
float: none; display: inline !important;\">Peru</span></td>
</tr>
<tr>
<td><span style=\"color: #37454d;\"><strong>Resort Address:</strong></span>
</td>
<td>
<div class=\"is-hidden-mobile blEntry address ui_link \" data-popover=\"small\"
data-position=\"below\" data-element=\".content\" data-
options=\"closeOnMouseAway\" data-maxwidth=\"300\" data-mapfilters=\"\">
<span>Unnamed Rd Urquillos, Peru</span></div>
</td>
</tr>
<tr>
<td><span style=\"color: #37454d;\"><strong>Website:</strong></span></td>
<td>
<p><span style=\"color: #37454d;\">https://www.explora.com/hotels-and-
travesias/sacred-valley-peru/</span></p>
</td>
</tr>
<tr>
<td><span style=\"color: #37454d;\"><strong>Phone:</strong></span></td>
<td><span style=\"color: #37454d;\">+56 2 2395 2580</span></td>
</tr>
</tbody>
</table>
<p><iframe style=\"border:0\" src=\"https://www.google.com/maps/embed?
pb=!1m14!1m8!1m3!1d15528.573314149919!2d-72.0483157!3d-
13.341359!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x0%3A0x1a052e519e34e771!
2sExplora+Valle+Sagrado!5e0!3m2!1sen!2sjp!4v1531275200849\" height=\"450\"
width=\"600\"></iframe></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}