using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^A-Za-z 0-9 \.,\?""!@#\$%\^&\*\(\)-_=\+;:<>\/\\\|\}\{\[\]`~|\xE0-\xE6|\xC0-\xC6|\xE8-\xEB|\xC8-\xCB|\xEC-\xEF|\xCC-\xCF|\xF2-\xF6|\xD2-\xD6|\xF9-\xFC|\xD9-\xDC|\xE7|\xC7|\xF1|\xD1]*";
string input = @"aÇÃO
ANÃO
único
Único
íma
irmão";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}