package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)hello\[\d+\]+`)
var str = `Hello[0] hello[2] hell Welcome to JavaScript.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}