$re = '/hello\[\d+\]+/i';
$str = 'Hello[0] hello[2] hell Welcome to JavaScript.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);