const regex = /\[\d{2}\.\d{2}\.\d{2}\s\d{2}\:\d{2}\:\d{2}\:\d{1,3}\sMET\].+The Application\s([a-zA-Z0-9]*)\sis starting\.[\s\S]*\[\d{2}\.\d{2}\.\d{2}\s\d{2}\:\d{2}\:\d{2}\:\d{1,3}\sMET\].+The Application started:\s\1/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d{2}\\.\\d{2}\\.\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\:\\d{1,3}\\sMET\\].+The Application\\s([a-zA-Z0-9]*)\\sis starting\\.[\\s\\S]*\\[\\d{2}\\.\\d{2}\\.\\d{2}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\:\\d{1,3}\\sMET\\].+The Application started:\\s\\1', 'mg')
const str = `[10.12.19 15:29:10:408 MET] 0000006a ApplicationMg A WSVR0200I: The Application query is starting.
[10.12.19 15:29:11:102 MET] 0000006a CompositionUn A WSVR0191I: Composition unit AB started
[10.12.19 15:29:11:222 MET] 0000006a CompositionUn A WSVR0191I: Composition unit CD started
[10.12.19 15:29:11:412 MET] 0000006a ApplicationMg A WSVR0200I: The Application tracer is starting.
[10.12.19 15:29:12:108 MET] 0000006a CompositionUn A WSVR0191I: Composition unit DE started.
[10.12.19 15:29:12:541 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: query
[10.12.19 15:29:13:417 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: tracer
[10.12.19 15:30:12:145 MET] 0000006a ApplicationMg A WSVR0200I: The Application test is starting.
[10.12.19 15:30:13:408 MET] 0000006a CompositionUn A WSVR0191I: Composition unit XY started.
[10.12.19 15:30:14:678 MET] 0000006a ApplicationMg A WSVR0200I: The Application started: test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}