$re = '/\bx\S+z\b/';
$str = 'xaz xazx xaxsza zsxdaszdx zasxz xaaz xaaaz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);