use strict;
my $str = '14½ oz gin
¾ oz fresh lemon juice
½ oz Lillet Blanc
0,5 dash angostura
1/2 oz Lillet Blanc
½ oz white crème de cacaot';
my $regex = qr/^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}