import re
regex = re.compile(r"^([0-9¼½¾]*|[0-9](\/|,|.)[0-9])\s(oz|cup|tsp|tbsp|dash)?\s", flags=re.MULTILINE)
test_str = ("14½ oz gin\n"
"¾ oz fresh lemon juice\n"
"½ oz Lillet Blanc\n"
"0,5 dash angostura\n"
"1/2 oz Lillet Blanc\n"
"½ oz white crème de cacaot")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")