$re = '/([<br\/>|<br>|<br \/>])?/m';
$str = '<br /> remove HTML breaks after this string <br/><br><br /><br/><br><br /><br /><br/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);