re = /([<br\/>|<br>|<br \/>])?/m
str = '<br /> remove HTML breaks after this string <br/><br><br /><br/><br><br /><br /><br/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end