package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?[\d?]+|[^=]`)
var str = `1+1=?
123*45?=5?088
-5?*-1=5?
19--45=5?
??*??=302?
?*11=??
??*1=??
??+??=??`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}