$re = '/-?[\d?]+|[^=]/m';
$str = '1+1=?
123*45?=5?088
-5?*-1=5?
19--45=5?
??*??=302?
?*11=??
??*1=??
??+??=??';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);