#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)(?:\G(?!\A)|begin).*?\K(keyword)(?=.*end)"
Local $sString = "begin" & @CRLF & _
"keyword" & @CRLF & _
"keyword " & @CRLF & _
"end" & @CRLF & _
"keyword" & @CRLF & _
"end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")