$re = '/(?:\G(?!\A)|begin).*?\K(keyword)(?=.*end)/xs';
$str = 'begin
keyword
keyword
end
keyword
end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);