$re = '/^(?:(?!boon\.ini|http).)*$\r?\n?/m';
$str = 'test http fail
test boon.htt match
test boon.ini fail
test boon.in match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);