re = /^(?:(?!boon\.ini|http).)*$\r?\n?/m
str = 'test http fail
test boon.htt match
test boon.ini fail
test boon.in match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end