re = /IDNUMBER: (\d\d\d-\w\w)/m
str = 'Ties de Kok (IDNUMBER: 123-AZ). Rest of Text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end