import re
regex = re.compile(r"^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)")
test_str = "Jose Jose Romulo Ricardo, lopez de montana."
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)