using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^_?C433.*$";
string input = @"_C433.P33200SP.txt
C433.P33200SP.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}