$re = '/^_?C433.*$/m';
$str = '_C433.P33200SP.txt
C433.P33200SP.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);