$re = '/([a-zA-Z0-9\']+)--([a-zA-Z0-9\']+)__([a-zA-Z0-9\']+)/';
$str = 'foo-bar--baz__foo--bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);