re = /([a-zA-Z0-9']+)--([a-zA-Z0-9']+)__([a-zA-Z0-9']+)/
str = 'foo-bar--baz__foo--bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end