#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[|\s]*\|\s*([^|\s]+)$"
Local $sString = "| John | Gilbert | alan" & @CRLF & _
"| Stephen | king | harris" & @CRLF & _
"| | Steve" & @CRLF & _
"| Barack | | Obama" & @CRLF & _
"|| Donald | | Trump " & @CRLF & _
"| | Alan" & @CRLF & _
"| | Stewart"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")