re = /^[|\s]*\|\s*([^|\s]+)$/m
str = '| John | Gilbert | alan
| Stephen | king | harris
| | Steve
| Barack | | Obama
|| Donald | | Trump
| | Alan
| | Stewart'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end