package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}$`)
var str = `Прасько Орест Гнатович
Хуба-Буба Мар'яна-Галина В'ячеславівна
Хуба-Буба Мар'яна-Галина В'ячеславівна-Василівна`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}