$re = '/^[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}$/mu';
$str = 'Прасько Орест Гнатович
Хуба-Буба Мар\'яна-Галина В\'ячеславівна
Хуба-Буба Мар\'яна-Галина В\'ячеславівна-Василівна';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);