#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:{{(?:(\d?\-?\d?)(:=?)('[^']*'),*).*?}})"
Local $sString = "0:'ingen',1:'menneske',2:'mennesker'" & @CRLF & _
"0:='ingen',-1:'fugl'" & @CRLF & _
"1:'cola',2-:'colar'" & @CRLF & _
"0:='ingen',0:'biler',1:'bil',2:'biler',3-:'bøller'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{{0:'ingen',1:'menneske',2:'mennesker'}}" & @CRLF & _
"{{0-2:='ingen',0-1:'fugl'}}" & @CRLF & _
"{{1:'cola',2-:'colar'}}" & @CRLF & _
"{{0:='ingen',0:'biler',1:'bil',2:'biler',3-:'bøller'}}" & @CRLF & _
"" & @CRLF & _
"Single ${{var}}" & @CRLF & _
"Vi er ${{var_U}}{{0:'ingen',1:'menneske',2:'mennesker'}}" & @CRLF & _
"Der er en ${{var_1}}{{0:='ingen',0-1:'fugl'}}" & @CRLF & _
"Gi' mig ${{var}}{{1:'cola',2-:'colar'}}" & @CRLF & _
"Jeg har ${{var}}{{0:='ingen',0:'biler',1:'bil',2:'biler',3-:'bøller'}} " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\$\{\{(.+)\}\}\{\{((\d)(\-)?(\d)?(:(=)?)\'(.+)\'),?\}\}" & @CRLF & _
"" & @CRLF & _
"\${{([A-Za-z\_\d]+)}}((?:{{)?((\d-?\d?)(:=?)\'(.*?)\'),?(?:}})?)?" & @CRLF & _
"" & @CRLF & _
"\${{(?P<var>[A-Za-z09_]+)}}({{(?:(?P<factorL>\d)?(?P<diff>\-)?(?P<factorH>\d)?(?P<assert>:=?)(\'(?P<string>.+?)\')+?)?}})?" & @CRLF & _
"" & @CRLF & _
"{{([A-Za-z0-9_]+)}}(?:{{((\d?\-?\d?)(:=?)('.+?'),?)+}})?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")