const regex = /<(\w+\:[\w.-]+)>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+\\:[\\w.-]+)>', 'gm')
const str = `<staticText:HelloWorld>_<xmlNode:Node.03>_<date:2011-12-12>_<time:23-59-11-222>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}