import re
regex = re.compile(r"\b(transfer|rent)\D+(\d+(?:[,.]\d+)*)", flags=re.MULTILINE)
test_str = ("19 Aug standing order rent Apolo Housing Assoc. 500.00 50.00\n"
"20 Aug transfer from John wick saving a/c 200.00 130.90")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")