$re = '/[A-Z]+(?![a-z])|[A-Z]?[a-z]+|\d+/m';
$str = 'ANet15Amount
ABCAnet15Amount
aaaBaBBBCaaCa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);