re = /[A-Z]+(?![a-z])|[A-Z]?[a-z]+|\d+/m
str = 'ANet15Amount
ABCAnet15Amount
aaaBaBBBCaaCa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end