package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)value\=\"(?<value>[^\"]*)\",operation\=\"(?<operation>[^\"]*)`)
var str = `[name="IP BLOCK TYPE",value="Private",operation="OVERRIDE"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}