re = /value\=\"(?<value>[^\"]*)\",operation\=\"(?<operation>[^\"]*)/m
str = '[name="IP BLOCK TYPE",value="Private",operation="OVERRIDE"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end