#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9]+)\b(.+)\b(\1)$"
Local $sString = "phase1 begin trial end phase1" & @CRLF & _
"phase2.begin distribution end phase2" & @CRLF & _
"phase3 allow buying in phase3 but" & @CRLF & _
"phase4 has no end" & @CRLF & _
"phase5 is test of phase"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")