re = /^([a-zA-Z0-9]+)\b(.+)\b(\1)$/m
str = 'phase1 begin trial end phase1
phase2.begin distribution end phase2
phase3 allow buying in phase3 but
phase4 has no end
phase5 is test of phase'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end