#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m):(?!(?:[^:]*?:){3,4}[^:]*$)"
Local $sString = "word1: word2: word3: word4: word5: word6: word7: word8 word9" & @CRLF & _
"" & @CRLF & _
"word1: word2: word3: word4: word5: word6: word7: word8 word9" & @CRLF & _
"" & @CRLF & _
"word1: word2: word3: word4: word5: word6: word7: word8 word9"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)