$re = '/:(?!(?:[^:]*?:){3,4}[^:]*$)/m';
$str = 'word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;