using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[?&]param=([^&]*)";
string input = @"https://www.heapanalytics.com?param=value1&foo=bar
https://www.heapanalytics.com?foo=bar¶m=value2&bar=baz
https://www.heapanalytics.com?foo=bar&bar=baz¶m=value3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}