$re = '/[?&]param=([^&]*)/m';
$str = 'https://www.heapanalytics.com?param=value1&foo=bar
https://www.heapanalytics.com?foo=bar¶m=value2&bar=baz
https://www.heapanalytics.com?foo=bar&bar=baz¶m=value3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);