$re = '/[ ]+(?=[^"]*(?:"[^"]*"[^"]*)*$)/';
$str = '"this is inside" and this is outside. "back in again".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);