re = /[ ]+(?=[^"]*(?:"[^"]*"[^"]*)*$)/
str = '"this is inside" and this is outside. "back in again".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end