$re = '/#(\w+)\.(\w+)/m';
$str = 'endpoint/?userId=#someuser.id
Hi #someuser.name, how are you?
# .id, #.id. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);