$re = '/^(?!\d{4}-\d{2}-\d{2}$)/m';
$str = 'some text
and more 1234
@#$%^^ text
1234-12-12
++++ MORE _________';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);