re = /^(?!\d{4}-\d{2}-\d{2}$)/m
str = 'some text
and more 1234
@#$%^^ text
1234-12-12
++++ MORE _________'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end