import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\"'](?![^\\\"']*?(?:value|id))[^\\\"']*(?:\\\":\\s\\\"|':\\su')\\b([a-fA-F\\d]{32})\\b";
final String string = "\"value\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"u_jira_status\": \"\", \"u_quarter_closed\": \"\", \"file_hash\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"escalation\": \"0\", \"upon_approval\": \"proceed\", \"correlation_id\": \"\", \"cyber_kill_change\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"sys_id\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"u_business_service\": \"\", \"destination_ip\": \"ef51be4506d7d287abc8c26ea6c495f6\", u'test': u'9db92f08db4f951423c87d84f39619ef'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}