const regex = /[\"'](?![^\"']*?(?:value|id))[^\"']*(?:\":\s\"|':\su')\b([a-fA-F\d]{32})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\"\'](?![^\\"\']*?(?:value|id))[^\\"\']*(?:\\":\\s\\"|\':\\su\')\\b([a-fA-F\\d]{32})\\b', 'gm')
const str = `"value": "ef51be4506d7d287abc8c26ea6c495f6", "u_jira_status": "", "u_quarter_closed": "", "file_hash": "ef51be4506d7d287abc8c26ea6c495f6", "escalation": "0", "upon_approval": "proceed", "correlation_id": "", "cyber_kill_change": "ef51be4506d7d287abc8c26ea6c495f6", "sys_id": "ef51be4506d7d287abc8c26ea6c495f6", "u_business_service": "", "destination_ip": "ef51be4506d7d287abc8c26ea6c495f6", u'test': u'9db92f08db4f951423c87d84f39619ef'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}