package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(xcopy)|([A-Z]:\\[^\s\n]*)+`)
var str = `xcopy C:\test D:\target\backup\files F:\abc.text
(xcopy)|([A-Z]:\\[^ \n]*)+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}