using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:origin\/develop|origin\/master|origin\/release\/\d+\.\d+\.\d+(?!.)|origin\/release\/\d+\.\d+\.\d+(?:_uat|_preprod))$";
string input = @"origin/release/0.0.0_uat
origin/master
feature
origin/feature/0.0.0
origin/develop
dev
origin/release/0.0.0
origin/release
origin/release/0_0_0
origin/release/0/0/0
origin/release/0.0.0_preprod
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}